VCOM:VectorWorks:Filing:IStdFile::OpenNewWrite
Jump to navigation
Jump to search
.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference
Description
namespace VectorWorks::Filing
Member of VCOM:VectorWorks:Filing:IStdFile
Opens a file for writing, truncating it if it exist. So the file will be always empty when starting to write in it.
virtual VCOMError VCOM_CALLTYPE OpenNewWrite(
IFileIdentifier* pFileID) = 0;
Parameters
pFileID IFileIdentifier* The file identifier to the file that is to be written.
Return Value
Uses standard VCOM Error Reporting.
Return value meaning:
kVCOMError_NotInitialized Bad VCOM instance used to call the fuction. kVCOMError_Failed Routine failed.
See Also
VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile
[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]