VCOM:VectorWorks:Filing:IRawOSFile::Open

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IRawOSFile

Open a file identifier for reading and/or writing.

virtual VCOMError VCOM_CALLTYPE Open(
IFileIdentifier* pFileID,
bool bReadable,
bool bWritable,
bool bRandomAccess,
bool bTruncateExisting) = 0;

Parameters

bTruncateExisting bool true if the file has to be cleared when opened for writing. When reading this has no effect. </line>

pFileID IFileIdentifier* The file identifier which should be opened.
bReadable bool True if the file has to be opened for reading.
bWritable bool true if the file has to be opened for writing.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IRawOSFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IRawOSFile]]