VCOM:VectorWorks:Filing:IRawOSFile::::Write

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IRawOSFile

Writes bytes into already opened file for writing.

virtual VCOMError VCOM_CALLTYPE Write(
Uint64 position,
Uint64 size,
const void* pBuffer) = 0;

Parameters

position Uint64 File offset from which the first byte of the sequence will be read.
size Uint64 Number of bytes that needs to be writted to the file.
pOutBuffer const void* Pointer to memory that will provide the bytes that will be written.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IRawOSFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IRawOSFile]]