VCOM:VectorWorks:Filing:IRawOSFile::::Read
From Vectorworks Developer
.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference
Description
namespaceVectorWorks::Filing
Member of VCOM:VectorWorks:Filing:IRawOSFile
Read bytes from previosly opened file for reading.
virtual VCOMError VCOM_CALLTYPE Read(
Uint64 position,
Uint64& inoutSize,
void* pOutBuffer) = 0;
Parameters
position Uint64 File offset from which the first byte of the sequence will be read. inoutSize Uint64& In out parameter. Receives number of bytes that is to be read. Returns the number of bytes actually read. pOutBuffer void* Pointer to memory that will receive the bytes that has been read.
Return Value
Uses standard VCOM Error Reporting.Return value meaning:
kVCOMError_NotInitialized Bad VCOM instance used to call the fuction. kVCOMError_Failed Routine failed.
See Also
VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IRawOSFile[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IRawOSFile]]