VCOM:VectorWorks:Filing:IPublish

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Filing

..put some descriptoin in here...

Interface

// {B5C21FF5-0A2C-498B-B876-90521EEC3BA6}
static const VWIID IID_Publish = { 0xb5c21ff5, 0xa2c, 0x498b, { 0xb8, 0x76, 0x90, 0x52, 0x1e, 0xec, 0x3b, 0xa6 } };

class DYNAMIC_ATTRIBUTE IPublish : public IVWUnknown
{
public:

	virtual VCOMError VCOM_CALLTYPE	Publish() = 0;

};

Members

Publish

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IPublish interface:

typedef VCOMPtr<IPublish>  IPublishPtr;

Version

Available from: Vectorworks 2015

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]