VCOM:VectorWorks:Filing:IImportExportSketchup::Export

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IImportExportSketchup

Export the active document layer into a Sketchup file. If the file is not specified it shows file choose dialog.

virtual VCOMError VCOM_CALLTYPE Export( ) = 0;
virtual VCOMError VCOM_CALLTYPE Export(
IFileIdentifier* pFileID) = 0;

Parameters

pFileID IFileIdentifier* The file that is to be exported into.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]]