VCOM:VectorWorks:Filing:IImportExportDWG::ImportSelectedFile

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IImportExportDWG

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE ImportSelectedFile(
IFileIdentifier* pFileID,
const bool isSilentDWGImport) = 0;

Parameters

pFileID IFileIdentifier* no info.
isSilentDWGImport const bool no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.