VCOM:VectorWorks:Filing:IFolderIdentifier::GetName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFolderIdentifier

Return the name of this folder.

virtual VCOMError VCOM_CALLTYPE GetName(
TXString& outName) = 0;

Parameters

outName TXString& Output parameter. Returns the name of this path.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_BadPathSpecified This path is invalid.

Remarks

For specific character handling see: IFolderIdentifier::Set

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]]