VCOM:VectorWorks:Filing:IFolderIdentifier::GetFullPath

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFolderIdentifier

Return full OS dependent path to this folder.

virtual VCOMError VCOM_CALLTYPE GetFullPath(
TXString& outPath) = 0;

Parameters

outPath TXString& Output parameter. Returns the full path represented by this instance.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_BadPathSpecified This path is invalid.

Remarks

This funtion returns specific OS path.

Windows path contains device name, and uses '\' for delimiter: "C:\temp\myFolder\"

Mac path uses POSIX path, and uses '/' for delimieter: "/Root/myFolder/"

The full path returned always contain path delimiter at the end.

For specific character handling see: IFolderIdentifier::Set

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]]