VCOM:VectorWorks:Filing:IFileIdentifier::SetFileName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Set file name with extension. If the name contains extension it is used for the file instance. if it doesn't contain extension, the extension in the instance is preserved.

'.' symbol is used to delimit the extension from the name.

virtual VCOMError VCOM_CALLTYPE SetFileName(
const TXString& name) = 0;

Parameters

name const TXString& New name for the file instance. The name may contain file extension, '.' delimits extension.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]