VCOM:VectorWorks:Filing:IFileIdentifier::SetAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Set attributes to this file.

virtual VCOMError VCOM_CALLTYPE SetAttributes(
const SAttributes& attributes) = 0;

Parameters

attributes const SAttributes& The new file attributes.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

attributes are obtained inside the structure: see remarks of IFolderIdentifier::GetAttributes.

Note Currently not implemented!

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]