VCOM:VectorWorks:Filing:IFileIdentifier::GetFileFullPath

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Return OS dependent full path to the file represented by this instance.

virtual VCOMError VCOM_CALLTYPE GetFileFullPath(
TXString& outPath) = 0;

Parameters

outPath TXString& Output parameter. Return the full path.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

This function returns specific OS path.

Windows path contains device name, and uses '\' for delimiter: "C:\temp\myFile.txt"

Mac path uses POSIX path, and uses '/' for delimieter: "/Root/myFile.txt"

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]