VCOM:VectorWorks:Filing:IFileIdentifier::FormatFilename

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

The passed name is clipped by the specified amount of characters. The clip is performed '...' is added at the end of the name but still the name if within the required amount of characters.

virtual VCOMError VCOM_CALLTYPE FormatFilename(
TXString& formatName,
Uint16 maxCharsWithoutSpace) = 0;

Parameters

formatName TXString& In Out Parameter. The name contained in this parameter is clipped by the specified amount of characters.
maxCharsWithoutSpace Uint16 Maximum character that the path should have.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]