VCOM:VectorWorks:Filing:IFileChooserDialog::SetDefaultFileName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileChooserDialog

Set default file name to be used in the dialog. The file name may contain extension ('.' as delimiter) which will be used as default extension.

virtual VCOMError VCOM_CALLTYPE SetDefaultFileName(
const TXString& name) = 0;

Parameters

name const TXString& The file name to be used.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]