VCOM:VectorWorks:Filing:IApplicationFolders::IsInStandardFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

virtual VCOMError VCOM_CALLTYPE IsInStandardFolder(
EFolderSpecifier folderSpec,
IFileIdentifier* pFileID,
IFolderIdentifier** ppOutPath) = 0;

Parameters

folderSpec EFolderSpecifier one of the folder constants in FolderSpecifiers.h
pFileID IFileIdentifier* The file to search for. Usually that will contain only file name.
ppOutPath IFolderIdentifier** Output parameter. The resulted path where the file is found.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError If the given file path is under the given standard folder class.
kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]