VCOM:VectorWorks:Filing:IApplicationFolders::GetNamedSubFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

virtual VCOMError VCOM_CALLTYPE GetNamedSubFolder(
IFolderIdentifier* pParentFolderID,
const TXString& partialPath,
IFolderIdentifier** ppOutPath) = 0;

Parameters

pParentFolderID IFolderIdentifier* no info
partialPath const TXString& no info
ppOutPath IFolderIdentifier** no info

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]