VCOM:VectorWorks:Filing:IApplicationFolders::GetFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

Returns the full path of the folder requested by inWhichFolder.

If the requested folder does not exist and inCreateIfMissing is true, then it will be created. Otherwise, it returns kVCOMError_Failed if the folder does not exist.

virtual VCOMError VCOM_CALLTYPE GetFolder(
EFolderSpecifier inWhichFolder,
IFolderIdentifier** ppOutPath,
bool bCreateIfMissing = false) = 0;

Parameters

inWhichFolder EFolderSpecifier <NO INFO>
ppOutPath IFolderIdentifier** Output parameter. Folder identifier of the found folder.
bCreateIfMissing bool Create the folder if missing if true.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]