VCOM:VectorWorks:Extension:IShapePaneWidgetAccess

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

..put some descriptoin in here...

Interface

...put the class definition, including the UUID, here...

Members

GetWidgetProvider
GetValueInt
SetValueInt
GetValueBool
SetValueBool
GetValueReal
SetValueReal
GetValueString
SetValueString
GetValueLong
SetValueLong
GetCurrentButton
SetHighlightPoint
ClearHighlightPoint
AddHighlightObject
RemoveHighlightObject

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IShapePaneWidgetAccess interface:

typedef VCOMPtr<IShapePaneWidgetAccess>  IShapePaneWidgetAccessPtr;

Version

Available from: Vectorworks 2010

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]