VCOM:VectorWorks:Extension:IProviderSpecialGroups

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

This interface allows the developer to provide custom strings to the UI to rename the "Path" and "Profile" groups. Also offers some additional control related to special edit groups.

GetPathGroupCustomTitleString0 - 2 The strings used to populate the Exit button when in edit mode.

GetContextMenuEdit____String The strings shown on the context edit menu instead of "Edit Path" or "Edit Profile"

GetChooseComponentDia____String The strings used in the radio buttons on the "Choose component dialog"

GetChooseComponentDia____HelpString The help strings used on the "Choose component dialog"

GetChooseComponentDiaDblClkPDMenu____String The strings used to populate the drop down list on the "Choose component dialog"

OnEnter____Group This function is called when the user enters a special group for edit. There are probably many ways to cause problems here...be careful.

Interface

...put the class definition, including the UUID, here...

Members

GetPathGroupCustomTitleString0
GetProfileGroupCustomTitleString0
GetPathGroupCustomTitleString1
GetProfileGroupCustomTitleString1
GetPathGroupCustomTitleString2
GetProfileGroupCustomTitleString2
GetContextMenuEditPathString
GetContextMenuEditProfileString
GetChooseComponentDiaPathString
GetChooseComponentDiaProfileString
GetChooseComponentDiaPathHelpString
GetChooseComponentDiaProfileHelpString
GetChooseComponentDiaDblClkPDMenuPathString
GetChooseComponentDiaDblClkPDMenuProfileString
AllowInPlaceEditBehavior
OnEnterProfileGroup
OnEnterPathGroup

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IProviderSpecialGroups interface:

typedef VCOMPtr<IProviderSpecialGroups>  IProviderSpecialGroupsPtr;

Version

Available from: Vectorworks 2013

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]