VCOM:VectorWorks:Extension:IObjUpdateSupport

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

..put some descriptoin in here...

Interface

// ----------------------------------------------------------------------------------------------------
// {6340A3C4-F7A7-4a42-9050-E4964F41E6F9}
static const VWGroupID GROUPID_ObjUpdateSupport = { 0x6340a3c4, 0xf7a7, 0x4a42, { 0x90, 0x50, 0xe4, 0x96, 0x4f, 0x41, 0xe6, 0xf9 } };

// ----------------------------------------------------------------------------------------------------
// Base class object update support implementations
class DYNAMIC_ATTRIBUTE IObjUpdateSupport : public IVWUnknown
{
public:
	virtual void 					VCOM_CALLTYPE Init(IObjUpdateSupportContext* theContext) = 0;
	
	virtual void 					VCOM_CALLTYPE OnState(IObjUpdateSupportContext* /*theContext*/, const ObjectState& /*state*/)			{ };
	virtual void 					VCOM_CALLTYPE OnStateInternal(IObjUpdateSupportContext* /*theContext*/, const ObjectState& /*state*/)	{ };
	virtual MCObjectHandle			VCOM_CALLTYPE PredrawGetOutputContainer(MCObjectHandle /*hOriginal*/)									{ return NULL; }
	virtual void 					VCOM_CALLTYPE OnPredraw(IObjUpdateSupportContext* /*theContext*/)										{ };
	virtual void 					VCOM_CALLTYPE OnPredrawLights(IObjUpdateSupportContext* /*theContext*/)									{ };
	virtual void 					VCOM_CALLTYPE OnNotification(IObjUpdateSupportContext* /*theContext*/)									{ };
	virtual EWeilerOperationResult 	VCOM_CALLTYPE OnWeilerOperation(IObjUpdateSupportContext* /*theContext*/)								{ return eWeilerOperationResult_NotHandled; };
	virtual bool					VCOM_CALLTYPE OnRightClick(IObjUpdateSupportContext* /*theContext*/)									{ return false; }
	virtual bool					VCOM_CALLTYPE OnResourceBrowserDoubleClickOnSymbol(IObjUpdateSupportContext* /*theContext*/, TXString& /*outActivateToolUniqueName*/)	{ return false; /*handled*/ };
};

Members

Init
OnState
OnStateInternal
PredrawGetOutputContainer
OnPredraw
OnPredrawLights
OnNotification
OnWeilerOperation
OnRightClick
OnResourceBrowserDoubleClickOnSymbol

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IObjUpdateSupport interface:

typedef VCOMPtr<IObjUpdateSupport>  IObjUpdateSupportPtr;

Version

Available from: Vectorworks 2010

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]