VCOM:VectorWorks:Extension:ILeaderLineProvider::SetLabelPt

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ILeaderLineProvider

Sets position for the leader line label point.

The position change is triggered by the Align/Distribute Leader Lines command so this function implements how the object will use the new position.

virtual VCOMErrorVCOM_CALLTYPE SetLabelPt(
MCObjectHandle hObject,
const WorldPt& pt) = 0;

Parameters

hObject MCObjectHandle the object which provides leader line shoulder point.
pt const SDK:WorldPt& new position.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.