VCOM:VectorWorks:Extension:ILeaderLineProvider::GetLeaderEndPt

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ILeaderLineProvider

Gets the leader line target point (the point where the leader line and the object's geometry touch).

virtual VCOMErrorVCOM_CALLTYPE GetLeaderEndPt(
MCObjectHandle hObject,
WorldPt& outPt) = 0;

Parameters

hObject MCObjectHandle the object which provides leader line shoulder point.
outPt SDK:WorldPt& the position.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.