VCOM:VectorWorks:Extension:ILeaderLineProvider::GetLabelPt

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ILeaderLineProvider

Gets position of the leader line label point.

virtual VCOMErrorVCOM_CALLTYPE GetLabelPt(
MCObjectHandle hObject,
WorldPt& outPt) = 0;

Parameters

hObject MCObjectHandle the object which provides leader line shoulder point.
outPt SDK:WorldPt& the position.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.