VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp2

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the property value from a property set.

VCOMError IFC_GetPsetProp2(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
TXString& outStrIfcPropValue,
short& iType,
short& outMap);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Property set name.
strIfcPropName TXString Property name.
outStrIfcPropValue TXString Returns the property value.
iType short Retruns the property type. Possible values: UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9).
outMap short Returns the source for the value. Possible values: eNotSet(-1); eFromInstance(0); eFromMapping(1). For more info: IFC Enumerations.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Note that this function returns only property values from properties. For values from Entities please use IFC_GetEntityProp2.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.

See Also

IFC_GetEntityProp2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]]