VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesList

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the list of members for an IFC entity

VCOMError IFC_GetPropertiesList(
EIFCSupportSchema scheme,
const TXString& strIfcObjName,
TXStringArray& outArrProperties,
TXStringArray& outArrDefaultValues);

Parameters

scheme EIFCSupportSchema IFC Scheme. Possible values are kIFCSupportScheme_2x2 (IFC 2x2); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4).
strIfcObjName TXString IFC entity name.
outArrProperties TXStringArray Returns list of entity members.
outArrDefaultValues TXStringArray Returns list of default values for entity members. Currently returning empty list.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NoInterface During SDK:GS_VWQueryInterface or VCOM:VCOMPtr notifying that there is no instance with requested VCOM:VWIID.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.