VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AddEntry

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Adds an entry to indicated object from current IFC Data Mapping.

VCOMError IFC_AddEntry(
const TXString& strObjectName,
const TXString& strEntryName,
bool bEnable,
EIfcEntityType eEntityType);

Parameters

strObjectName TXString Object Name.
strEntryName TXString Ifc Entity Name.
bEnable bool Boolean that determines whether the entry is enabled or disabled.
eEntityType EIfcEntityType Entry Type. Possible values are ePrimary, eSecondary and eUnknown

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.