VCOM:VectorWorks:Extension:IGISSupport::GetProjectionProj4

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IGISSupport

Get the projection information in Proj4 format.

virtual VCOMErrorVCOM_CALLTYPE GetProjectionProj4(
bool esriStyle,
TXString& outValue) = 0;

Parameters

esriStyle bool no info.
outValue SDK:TXString& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.