VCOM:VectorWorks:Extension:IDTMTIN::GetTrianglesCount

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Gets the count of the Site model's triangles (from the Site model's triangulation).

virtual VCOMErrorVCOM_CALLTYPE GetTrianglesCount(
size_t& outCount) = 0;

Parameters

outCount size_t& resulting count.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.