VCOM:VectorWorks:Extension:IDTMTIN::GetBoundedVolumeInfo

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

// Calculates the volume informations from the region of the Site model under the bounding poly.

virtual VCOMErrorVCOM_CALLTYPE GetBoundedVolumeInfo(
IPolyDef* inBoundPoly2D,
double& outVolumeExisting,
double& outVolumeProposed) = 0;

Parameters

inBoundPoly2D IPolyDef* the bounding poly.
outVolumeExisting double& resulting existing volume.
outVolumeProposed double& resulting proposed volume.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.