VCOM:VectorWorks:Extension:IDTMTIN::GetBoundedVolumeCutNFillInfo

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Calculates the cut & fill informations from the region of the Site model under the bounding poly.

virtual VCOMErrorVCOM_CALLTYPE GetBoundedVolumeCutNFillInfo(
IPolyDef* inBoundPoly2D,
double& outVolumeCut,
double& outVolumeFill) = 0;

Parameters

inBoundPoly2D IPolyDef* the bounding poly.
outVolumeCut double& resulting cut volume.
outVolumeFill double& resulting fill volume.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.