VCOM:VectorWorks:Extension:IDTMTIN::GetBalancingPadPoly

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Having a 2D grade limits poly, find a balancing flat 3D pad polygon (i.e. the amount of cut will be equal to the amount of fill) which forms specified slope to the glade limits surface polygon (the 3D projection of the 2D grade limits poly on the Site model surface).

virtual VCOMErrorVCOM_CALLTYPE GetBalancingPadPoly(
IPolyDef* inPoly2D,
IPolyDef** ppOutPoly3D,
double batterSlope) = 0;

Parameters

inPoly2D IPolyDef* Input parameter. a 2D polygon (represents a grade limits object).
ppOutPoly3D IPolyDef** Output parameter. Return a 3D polygon (the balancing 3D pad polygon).
batterSlope double the slope which the resulting balancing 3D pad polygon forms to the glade limits surface polygon (the 3D projection of the 2D grade limits poly on the Site model surface).

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.