VCOM:VectorWorks:Extension:IDTMNotificationListener::OnResetModel

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMNotificationListener

...put some description here...

virtual voidVCOM_CALLTYPE OnResetModel(
MCObjectHandle hDTMObject,
EDTMResetModel whatResets,
IDTMTIN* existTIN,
IDTMTIN* propTIN) = 0;

Parameters

hDTMObject MCObjectHandle no info.
whatResets EDTMResetModel no info.
existTIN IDTMTIN* no info.
propTIN IDTMTIN* no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.