VCOM:VectorWorks:Extension:IDTMLibrary::GetZatXY

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMLibrary

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE GetZatXY(
MCObjectHandle hDTMObj,
const WorldCoord inX,
const WorldCoord inY,
WorldCoord& outZ) = 0;

Parameters

hDTMObj MCObjectHandle no info.
inX const WorldCoord no info.
inY const WorldCoord no info.
outZ WorldCoord& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.