VCOM:VectorWorks:Extension:IDTMLibrary::FindDTMObjectAtXY

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMLibrary

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE FindDTMObjectAtXY(
MCObjectHandle hLayer,
double x,
double y,
MCObjectHandle& hOutDTMObj) = 0;

Parameters

hLayer MCObjectHandle no info.
x double no info.
y double no info.
hOutDTMObj MCObjectHandle& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.