VCOM:VectorWorks:Extension:IDBSupport::GetFormatFieldConnection

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBSupport

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE GetFormatFieldConnection(
MCObjectHandle hFormat,
TXString& inoutfieldName,
TXString& inoutColumnName,
EDBSupportLinkType& outLinkType) = 0;

Parameters

hFormat MCObjectHandle no info.
inoutfieldName SDK:TXString& no info.
inoutColumnName SDK:TXString& no info.
outLinkType EDBSupportLinkType& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.