VCOM:VectorWorks:Extension:IDBConnectionString

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

..put some descriptoin in here...

Interface

...put the class definition, including the UUID, here...

Members

Get
Set
Set
SetConnectionParams
GetConnectionParams
GetDriverID
SetDriverID
SetDriverID
GetDriver
SetDriver
GetDSN
SetDSN
IsDSNEmpty
GetSDSN
SetSDSN
GetDBQ
SetDBQ
GetDefaultDir
SetDefaultDir
GetServer
SetServer
GetDataBase
SetDataBase
GetExtensions
SetExtensions
GetProvider
SetProvider
GetDataSource
SetDataSource
GetExtProp
SetExtProp
GetUsername
SetUsername
GetFIL
SetFIL
GetHost
SetHost
GetPort
SetPort
GetPassword
SetPassword
HasPassword

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IDBConnectionString interface:

typedef VCOMPtr<IDBConnectionString>  IDBConnectionStringPtr;

Version

Available from: Vectorworks 2010

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]