SDK:Vectorworks 2009 New Functions
From Vectorworks Developer
.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference
ISDK Interface
List of new functions in the ISDK interface.
- ForEachFileInStandardFolder
- ForEachFilePathInStandardFolder
- ForEachFilePathInFolder
- ForEachFilePathInPluginFolder
- GetActiveDocument
- OpenDocumentPath
- SaveActiveDocumentPath
- EncryptVSPluginFilePath
- ReadVSExternalFilePath
- ImportDXF
- WriteMaterialImageFile
- ReadMaterialImageFile
- ClearComponentInstances
- FindFirstComponentInstance
- FindNextComponentInstance
- AssignAsComponentInstance
- EnableComponentInstance
- IsEnabledComponentInstance
- GetComponentInstanceTypeID
- SetComponentInstanceName
- GetComponentInstanceName
- EmptyToolHighlightingList
- AddToolHighlightingObject
- AddToolHighlightingSegment
- AddToolHighlightingPolyCreate
- AddToolHighlightingPoly
- AddToolHighlightingPolyAddVertex
- AddToolHighlightingSegment3D
- AddToolHighlightingPoly3DCreate
- AddToolHighlightingPoly3D
- AddToolHighlightingPoly3DAddVertex
- OpenURL
- ConvertNurbsToPolylineArcs
- CreateOffsetObjectHandle
- UnfoldSurface
- CreateWallHoleGroup
- GetWallHoleGroup
- CreateSymbolDisplayControlScaleByZoom
- UpdateSymbolDisplayControlScaleByZoom
- SetDefaultTextureMapping
- GetTextureMappingInfo
- SetTextureMappingInfo
- PerformMultipleUnion
- GetWorksheetSubrowHeight
- SetCustomObjectWallHoleGroup
- GetCustomObjectSelectionGroup
- SetCustomObjectSelectionGroup
- CreateWallFootPrint
- ExportResource
- CallDefaultTool
- EnableDrawingWorksheetPalette
- GetWorksheetAutoRecalcState
- SetWorksheetAutoRecalcState
IApplicationFolders Interface
List of new functions in the IApplicationFolders interface.
- IsInStandardFolder
- FindFileInPluginFolder
- GetFilePathInStandardFolder
- GetFilePathInUserRoot
- GetFolder
- GetNamedSubFolder
IWorkspaceFile Interface
List of new functions in the IWorkspaceFile interface.