SDK:TextureMappingInfoSDK
From Vectorworks Developer
.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference
Description
namespaceVectorWorks
Member of VCOM:VectorWorks:ISDK
This structure is used to apply a texture resource to a particular object's texture part. It sets the mapping type, the 3D location and orientation for the mapping (the transform from object space to texture space), the 2D modifiers, and additional mapping options.
struct TextureMappingInfoSDK { // Normalized 3D axis vectors and 3D offset from parameter space's // default center (bottom center for cylinder, front bottom left for planar, etc.). // Transforms from object space to texture space. _TransformMatrix fOriginOrient; Boolean fInitialized; // True if the the values have been set in a meaningful way // EParamSpaceKind: planar, spherical, cylindrical, or algorithmic short fParamSpaceKind; // Texture bitmap modifiers WorldPt f2DOffset; double f2DScale; double f2DRotation; // radians // Spherical and cylindrical space only // The feature length of the texture bitmap is true size on the sphere or // cylinder surface. The radius value lets the user shrink or expand this // surface. WorldCoord fRadius; Boolean fFlipTexture; // This is to indicate whether texture gets fliped horizontally or vertically. // with combination of rotation angle and offset, it achieves flipping Boolean fRepeatH; // Repeat texture along horizontal direction Boolean fRepeatV; // Repeat texture along vertical direction Boolean fAutoAlignPlanar; Boolean fAutoAlignPlanarLongestEdge; Boolean fUseWorldZ; };
Version
Availability: from VectorWorks 2009See Also
VCOM:VectorWorks:ISDK::SetDefaultTextureMapping | VCOM:VectorWorks:ISDK::GetTextureMappingInfo | VCOM:VectorWorks:ISDK::SetTextureMappingInfo | SDK:TexturePartSDK | SDK:TextureMappingInfoSDK[[VCOM:VectorWorks:ISDK::SetDefaultTextureMapping]] | [[VCOM:VectorWorks:ISDK::GetTextureMappingInfo]] | [[VCOM:VectorWorks:ISDK::SetTextureMappingInfo]] | [[SDK:TexturePartSDK]] | [[SDK:TextureMappingInfoSDK]]