SDK:Multiple Extrude

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

By François de Felix

What's that

This article will explain how to create a multiple extrude using the SDK.

To create an empty multiple extrude object, use :

	gSDK->Kludge( 3800, doubleParams, &multiExtrude );
  • doubleParams is a pointer to an array of 2 double_params (bottom and top of the extrude).
  • multiExtrude is a handle on the resulting multiple extrude object.

Example

MCObjectHandle CreateMultiExtrude(MCObjectHandle obj1, MCObjectHandle obj2, WorldCoord bottom, WorldCoord top)
{
	
	MCObjectHandle multiExtrude;
	double doubleParams[] = {bottom, top};
	gSDK->Kludge( 3800, doubleParams, &multiExtrude );
	     // now multiExtrude is a handle on my new empy multiple extrude

	gSDK->AddObjectToContainer(obj1, multiExtrude );
	gSDK->AddObjectToContainer(obj2, multiExtrude );
             // you can add more than 2 objects in your extrude

	gSDK->ResetObject(multiExtrude);
	
	return multiExtrude;
}

See also

VCOM:VectorWorks:ISDK::Kludge