Help:Adding VCOM Function Reference

From Vectorworks Developer
Jump to navigation Jump to search

.Help:Contents|Help ..Help:Contents|General Help ..Help:Adding Article|Adding Article ..Help:Adding Function Reference|Adding Function Reference ..Help:Adding General Function Reference|Adding General Function Reference ..Help:Adding VCOM Function Reference|Adding VCOM Function Reference ..Help:Adding VectorScript Function Reference|Adding VectorScript Function Reference

Naming

The actual type of the reference page (is it VectorScript or SDK or VCOM) is determined by the category in which the page exist.

The category is represented in the name before the semi-colon in the name.

For example "SDK:Something" is a page "Something" in category "SDK".

IMPORTANT Be careful when naming pages. The name is very important!

See See Help:Contents#Page Name

Interface Definition Page

Here is information of how to format general function reference page.

More information on the pages and the tags here Help:Adding Function Reference.

Here is template for interface definition reference page:

__TOC__
<vwDoc>

-----------------------------------------------------------------------------------------------------------
<desc>
namespace <code>VectorWorks::_namespace_name1_::namespace_name2_</code>

... some description ...
</desc>

-----------------------------------------------------------------------------------------------------------
<interface>
<code lang="cpp">
... C++ declaration of the interface ...
</code>
</interface>

-----------------------------------------------------------------------------------------------------------
<members>
<lineList ident=1>
<line>
[[VCOM:VectorWorks:_namespace_name1_:_namespace_name2_:I_interface_name_::_function_name_|_function_name_]]
...member information...
</line>
</lineList>
</members>

-----------------------------------------------------------------------------------------------------------
<return>
</return>

-----------------------------------------------------------------------------------------------------------
<remarks>
</remarks>

-----------------------------------------------------------------------------------------------------------
<sample>
</sample>

-----------------------------------------------------------------------------------------------------------
<version>
</version>

-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>

</vwDoc>

[[Category:VCOM:_namespace1_:_namespace2_|_interface_name_]]

Interface Function Page

Here is template for interface function reference page:

__TOC__
<vwDoc>

-----------------------------------------------------------------------------------------------------------
<desc>
namespace <code>VectorWorks::_namespace_name1_::namespace_name2_</code>

Member of [[VCOM:VectorWorks:_namespace_name1_:_namespace_name2_:I_interface_name_]]

... some description ...
</desc>

-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="cpp">
... C++ declaration of the function ...
</funcDef>
</def>

-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
...parameter name...
...parameter type...
...member information...
</line>
</lineList>
</params>

-----------------------------------------------------------------------------------------------------------
<return>
</return>

-----------------------------------------------------------------------------------------------------------
<remarks>
</remarks>

-----------------------------------------------------------------------------------------------------------
<sample>
</sample>

-----------------------------------------------------------------------------------------------------------
<version>
</version>

-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>

</vwDoc>

[[Category:VCOM:_namespace1_:_namespace2_:I_interface_name_|_function_name_]]

Remarks

The interface page name follows strict naming pattern. The categories (':' delimiter) in the name represent the namespaces that this interface is defined in.

The description of the interface definition contains namespace of where this interface is defined. '::' is used to delimit the namespace.

The interface definition members are defined in list table with two elements. The first entry is link to the function reference help page describing that interface function.

The interface definition member function link follows strict naming pattern. The categories (':' delimiter) are used to denote in which interface this function is localed, and this interface in what namespaces is defined. The '::' symbol is used to delimit the function name from the interface name representing belonging.

The page category is very important to ensure good documentation. '|' is used to delimit the sorting name when this page is shown in the category page.

The interface definition reference page participates in category named full namespace path to the interface, and ':' is used to delimit the namespaces.

The sorting name of the interface definition does NOT contain 'I' at the beginning, or all interfaces will fall into one group 'I'!!!

The sorting name of the interface function contains only the name of the function.

See Also