Vectorworks Scripting

From Vectorworks Developer
Revision as of 20:59, 16 June 2015 by Root (talk | contribs)
Jump to navigation Jump to search

.Vectorworks Scripting|Scripting ..Python|Python Scripting ..VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Vectorworks provides two options for scripting: Python (as of Vectorworks 2014) and VectorScript.

Python Scripting

Vectorworks 2014 adds [Python] language as an alternative to VectorScript for creating menu commands, objects, tools, or general purpose scripts.

You can go to the Python page for more information.

VectorScript

VectorScript is a Pascal-like language allowing scripting in Vectorworks.

VectorScript function reference is available here.

You can also use the main VectorScript category to help navigate.

Common Tasks

Installing Scripts

When, for the first time, you create a plug-in, Vectorworks puts all of its content in user plug-in path and each time Vectorworks runs it recursiveley load all the Plug-Ins in that path (Also looking for the short-cuts). When you designed and implemented your plug-in in either of the scripting languages, you may want to use it on different machines or VW instances. Vectorworks Plug-in manager allows users to install packages containing scripts and other content. For basic installation it just simply copy provided plug-in (which should be as a zip file) into the user plug-in path. Also if a installation scrpit is provided it will run that script as well. Please follow below links for more explanations and examples.

Version Information


Obsolete Functions Table

Find the full version table for all obsolete functions here:

VS:Obsolete Functions Table