VectorScript/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(4 intermediate revisions by the same user not shown)
Line 2: Line 2:
== VectorScriptとは? ==
== VectorScriptとは? ==


VectorScriptはVectorworks® Fundamentalsソフトウェアパッケージのスクリプト言語です。計量のプログラミング言語で、Pascalに似た文法を持ち、そこから多くのプログラム構造を取り入れています。
VectorScriptはVectorworks® Fundamentalsソフトウェアパッケージのスクリプト言語です。軽量のプログラミング言語で、Pascalに似た文法を持ち、そこから多くのプログラム構造を取り入れています。


== ランゲージガイド ==
== ランゲージガイド ==


VectorScript is actually a “superset” of the Pascal language, extending basic Pascal capabilities with a number of APIs (application programming interfaces) which provide access to the features and functionality of the Vectorworks CAD engine.
VectorScript はPascal言語の“スーパーセット”で、、Vectorworks のCADエンジンの機能を利用するために、基本的なPascalを、多くのAPI(Application Programing Interfaces)で拡張しています。


Please, download and read the [[Media:VectorScriptGuide.pdf|VectorScript Language Guide PDF]] document for more information.
詳しくは、 [[Media:VectorScriptLanguageGuide.pdf|VectorScript ランゲージガイド PDF]] をダウンロードしてお読みください。


== 基礎 ==
== 基礎 ==


[[VS:Introduction]]
* [[VS:Introduction]]
* [[VS:User Interface]]
* [[VS:Creating a Custom Dialog Box]]
* [[VS:Plug-in Parameter Types]]
* [[VS:Search Criteria]]
* [[VS:Include Files and Encryption]]
* [[VS:The VectorScript Debugger]]


[[VS:User Interface]]
== 一般的な例 ==


[[VS:Creating a Custom Dialog Box]]
* [[VS:Parametric Custom Opening in Wall]]
* [[VS:Parametric Custom Selection Indication]]
* [[VS:Parametric Custom Shape Pane]]
* [[VS:Parametric Custom Shape Pane Popup]]
* [[VS:Parametric Hide Details]]
* [[VS:Parametric State Notifications]]
* [[VS:Similar Objects Creation]]


[[VS:Plug-in Parameter Types]]
== バージョン情報 ==


[[VS:Search Criteria]]
*[[VS:Vectorworks 2009 Development|Vectorworks 2009]]
 
*[[VS:Vectorworks 2010 Development|Vectorworks 2010]]
[[VS:Include Files and Encryption]]
*[[VS:Vectorworks 2011 Development|Vectorworks 2011]]
 
*[[VS:Vectorworks 2012 Development|Vectorworks 2012]]
[[VS:The VectorScript Debugger]]
*[[VS:Vectorworks 2013 Development|Vectorworks 2013]]
*[[VS:Vectorworks 2014 Development|Vectorworks 2014]]

Latest revision as of 06:55, 21 February 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

VectorScriptとは?

VectorScriptはVectorworks® Fundamentalsソフトウェアパッケージのスクリプト言語です。軽量のプログラミング言語で、Pascalに似た文法を持ち、そこから多くのプログラム構造を取り入れています。

ランゲージガイド

VectorScript はPascal言語の“スーパーセット”で、、Vectorworks のCADエンジンの機能を利用するために、基本的なPascalを、多くのAPI(Application Programing Interfaces)で拡張しています。

詳しくは、 VectorScript ランゲージガイド PDF をダウンロードしてお読みください。

基礎

一般的な例

バージョン情報