VS:wsEditAddTool2

From Vectorworks Developer
Revision as of 22:12, 7 November 2017 by Aghosh (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Add a menu under Third-party palette and companyName tool set. The menu is added underneath another existing tool in the tool set.


Tool Type Constant
Regular External Tool 1
VectorScript Tool (.vst) 2
VectorScript Object (.vso) 3
Custom Parametric 4

Note: The Custom Parametric tool type includes SDK objects of type Point, Line, Box, 2D Path, and 3D Path.

PROCEDURE wsEditAddTool2(
toolName :STRING;
underToolName :STRING;
toolType :INTEGER);
def vs.wsEditAddTool2(toolName, underToolName):
    return None

Parameters

toolName STRING
underToolName STRING
toolType INTEGER

Version

Availability: from Vectorworks 2018