VS:vsoEquipItemDataGet: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 11:05, 3 February 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified equipment item data from the ParametricEquipmentItemDataMessage(92) message sent to a Script object based on the dataIndex. Returns false if this value is not available.

FUNCTION vsoEquipItemDataGet(
message :LONGINT;
dataIndex :INTEGER;
VAR outValue :STRING) : BOOLEAN;
def vs.vsoEquipItemDataGet(message, dataIndex):
    return (BOOLEAN, outValue)

Parameters

message LONGINT
dataIndex INTEGER
outValue STRING

Version

Availability: from Vectorworks 2023.4