VS:WriteLnMac

From Vectorworks Developer
Revision as of 14:50, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Writes a line of data to a text file using Macintosh character encoding for extended ASCII characters (128-255). This allows extended character data to be properly read and displayed by VectorWorks on Windows systems (VectorWorks by default uses Macintosh encoding for extended character values).

The line of data written to file is terminated with a return character combination appropriate for the platform on which the file is being written.

PROCEDURE WriteLnMac(
z :ANY);
def vs.WriteLnMac(z):
    return None

Parameters

z ANY

Example

VectorScript

PROCEDURE Example;
CONST
Vendor = 'ACME';
Price = 123.45;
Tax = 1.07;
BEGIN
Open('Output.txt');
WriteLnMac('Mfr/Cost: ', Vendor, '/', Price + Tax);
Close('Output.txt');
END;
RUN(Example);

Python


Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:WriteLn

VS Functions: [[VS:WriteLn]]