VS:Write: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (Reverted edits by Ptr (talk) to last revision by Root)
 
(5 intermediate revisions by 2 users not shown)
Line 39: Line 39:
<code lang="pas">
<code lang="pas">
Write(Value1);</code>
Write(Value1);</code>
Writing binary data:
:Write of ARRAY OF INTEGER with write two bytes per INTEGER. So, 10 bytes will be written for 'arr'.
:This code will produce file with the following bytes(hex): 01 02 FF FE 00 00 00 00 00 00
<code lang="pas">
  arr : ARRAY [1..5] OF INTEGER;
  FUNCTION MixBytes(b1, b2: INTEGER) : INTEGER;
  BEGIN
    MixBytes := b1 + b2 * 256;
  END;
BEGIN
  arr[1] := MixBytes( 1, 2 );
  arr[2] := MixBytes( 255, 254 );
  Write(arr);
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">

Latest revision as of 14:33, 2 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Write outputs the specified data to an ASCII text file. The variable length parameter list specifies the data to be written to the file.

Parameters may be any valid data type, and data types may be mixed in a single call to the procedure. Write leaves the file pointer positioned at the end of the last data value written to the file; any data subsequently written to the file will be appended to the end of this value.

See the VectorScript Language Guide for details on formatting values using WriteLn.

PROCEDURE Write(
z :ANY);
def vs.Write(z):
    return None

Parameters

z ANY

Example

VectorScript

Write(Value1);

Writing binary data:

Write of ARRAY OF INTEGER with write two bytes per INTEGER. So, 10 bytes will be written for 'arr'.
This code will produce file with the following bytes(hex): 01 02 FF FE 00 00 00 00 00 00
  arr : ARRAY [1..5] OF INTEGER;
	
  FUNCTION MixBytes(b1, b2: INTEGER) : INTEGER;
  BEGIN
    MixBytes := b1 + b2 * 256;
  END;
BEGIN
  arr[1] := MixBytes( 1, 2 );
  arr[2] := MixBytes( 255, 254 );
  Write(arr);

Python


Version

Availability: from All Versions