VS:WSScript GetObject

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function must be used inside a worksheet script called by 'RunScript' worksheet formula.

FUNCTION WSScript_GetObject : HANDLE;
def vs.WSScript_GetObject():
    return HANDLE

Return Value

Returns the object currently being processed by the worksheet criteria at the time of the script execution.

Remarks

_c_ (2021.02.08):

See excellent intrduction to Worksheet Scripting by Pat Stanford on the Techboard:

forum.vectorworks.net/index.php?/topic/75193-a-super-short-course-in-worksheet-scripts/

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:WSScript_GetObject | VS:WSScript_GetPrmInt | VS:WSScript_GetPrmReal | VS:WSScript_GetPrmStr | VS:WSScript_SetResStr | VS:WSScript_SetResReal | VS:WSScript_SetResImage

VS Functions:

[[VS:WSScript_GetObject]] | [[VS:WSScript_GetPrmInt]] | [[VS:WSScript_GetPrmReal]] | [[VS:WSScript_GetPrmStr]] | [[VS:WSScript_SetResStr]] | [[VS:WSScript_SetResReal]]

| [[VS:WSScript_SetResImage]]