VS:Str2Num

From Vectorworks Developer
Revision as of 06:52, 18 November 2018 by CBM-c- (talk | contribs) (xpln)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Str2Num returns the specified string as a numeric value.

FUNCTION Str2Num(
s :STRING) : REAL;
def vs.Str2Num(s):
    return REAL

Parameters

s STRING Source string.

Remarks

(Orso, 18 Nov. 17): Please be careful with overriding standard routines. I change the name of this routine into MyStr2Num. Thus it won't override the standard Str2Num.

Author unknown, changed so that it doesn't override the standard routine:

FUNCTION MyStr2Num(str :STRING) :REAL;
{This is more robust than Str2Num because it handles unit marks in the string,
while the built-in FUNCTION does not. Returns zero
if it fails, which of course does not unambiguously
indicate failure, but it's the same thing that Str2Num 
returns on failure (without the warning). If you need
to know whether or not the FUNCTION succeeded, you
shouldn't be using Str2Num, but ValidNumStr instead.}
VAR
num :REAL;
BEGIN
MyStr2Num := 0;
IF ValidNumStr(str, num) THEN MyStr2Num := num;
END;

Example

VectorScript

numValue:=Str2Num('235.44');

Python


Version

Availability: from All Versions

See Also

VS Functions:

VS:ValidNumStr

VS Functions: [[VS:ValidNumStr]]