VS:SetTextFont

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTextFont sets the font of a substring in the referenced text object.

PROCEDURE SetTextFont(
objectHd :HANDLE;
Start :INTEGER;
Count :INTEGER;
FontNum :INTEGER);
def vs.SetTextFont(objectHd, Start, Count, FontNum):
    return None

Parameters

objectHd HANDLE Handle to text object.
Start INTEGER Start position in text string.
Count INTEGER Length of substring.
FontNum INTEGER Font ID for substring.

Remarks

Note that "Start" is zero-based.

Example

VectorScript

SetTextFont(handleToText,0,5,GetFontID('Helvetica'));

{sets the first five characters of the referenced text string to Helvetica}

Python


Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:GetFontID

VS Functions: [[VS:GetFontID]]