VS:SetRRDiam: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(2 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets the diameters of a rounded rectangle.
Sets the diameters of a rounded rectangle.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE SetRRDiam(h :HANDLE; xDiam :REAL; yDiam :REAL);
PROCEDURE SetRRDiam(h:HANDLE; xDiam:REAL; yDiam:REAL);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 39: Line 38:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
VAR
  h :HANDLE;
  x, y :REAL;
BEGIN
  h := FSActLayer;
  IF (h = NIL) | (GetType(h) <> 13) THEN BEGIN
      CallTool(-217);
      h := FSActLayer;
  END;
  GetRRDiam(h, x, y);
  SetRRDiam(h, x * 2, y * 2);
END;
RUN(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|SetRRDiam]]
[[Category:VS Function Reference|SetRRDiam]]
[[Category:VS Function Reference:Objects - 2D|SetRRDiam]]
[[Category:VS Function Reference:Object Editing|SetRRDiam]]

Latest revision as of 17:38, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the diameters of a rounded rectangle.

PROCEDURE SetRRDiam(
h :HANDLE;
xDiam :REAL;
yDiam :REAL);
def vs.SetRRDiam(h, xDiam, yDiam):
    return None

Parameters

h HANDLE
xDiam REAL
yDiam REAL

Version

Availability: from Vectorworks 2014